# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))/$1$2decode_p2( $3 ,$5 )/gm;t' <<< " valami.decode(\"utf-8\", \"replace\")
str(temp[0].decode('utf-8'))
asd(str(temp[0].decode('Windows-1250'))) qwe
s += str(args[i]).decode('windows-1250', 'replace')"