# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$"
test_str = ("-- control group\n"
"AA9A 9AA\n"
"A9A 9AA\n"
"A9 9AA\n"
"A99 9AA\n"
"AA9 9AA\n"
"AA99 9AA\n\n"
"-- other characters aren't allowed in place of space\n"
"SA12x33B\n"
"SA12x3BB\n"
"SA12x3B\n\n"
"-- no spaces\n"
"SA1233B\n"
"SA123BB\n"
"SA123B\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.