$re = '/^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$/mi';
$str = '-- control group
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
-- other characters aren\'t allowed in place of space
SA12x33B
SA12x3BB
SA12x3B
-- no spaces
SA1233B
SA123BB
SA123B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);