const regex = /^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z]{1,2}[a-z0-9]{1,2})\\s*?(\\d[a-z]{2})$', 'gmi')
const str = `-- control group
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
-- other characters aren't allowed in place of space
SA12x33B
SA12x3BB
SA12x3B
-- no spaces
SA1233B
SA123BB
SA123B
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}