using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$";
string input = @"-- control group
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
-- other characters aren't allowed in place of space
SA12x33B
SA12x3BB
SA12x3B
-- no spaces
SA1233B
SA123BB
SA123B
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}