#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$"
Local $sString = "-- control group" & @CRLF & _
"AA9A 9AA" & @CRLF & _
"A9A 9AA" & @CRLF & _
"A9 9AA" & @CRLF & _
"A99 9AA" & @CRLF & _
"AA9 9AA" & @CRLF & _
"AA99 9AA" & @CRLF & _
"" & @CRLF & _
"-- other characters aren't allowed in place of space" & @CRLF & _
"SA12x33B" & @CRLF & _
"SA12x3BB" & @CRLF & _
"SA12x3B" & @CRLF & _
"" & @CRLF & _
"-- no spaces" & @CRLF & _
"SA1233B" & @CRLF & _
"SA123BB" & @CRLF & _
"SA123B" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")