package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$`)
var str = `-- control group
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
-- other characters aren't allowed in place of space
SA12x33B
SA12x3BB
SA12x3B
-- no spaces
SA1233B
SA123BB
SA123B
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}