import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]{1,2}[a-z0-9]{1,2})\\s*?(\\d[a-z]{2})$";
final String string = "-- control group\n"
+ "AA9A 9AA\n"
+ "A9A 9AA\n"
+ "A9 9AA\n"
+ "A99 9AA\n"
+ "AA9 9AA\n"
+ "AA99 9AA\n\n"
+ "-- other characters aren't allowed in place of space\n"
+ "SA12x33B\n"
+ "SA12x3BB\n"
+ "SA12x3B\n\n"
+ "-- no spaces\n"
+ "SA1233B\n"
+ "SA123BB\n"
+ "SA123B\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}