use strict;
my $str = '-- control group
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
-- other characters aren\'t allowed in place of space
SA12x33B
SA12x3BB
SA12x3B
-- no spaces
SA1233B
SA123BB
SA123B
';
my $regex = qr/^([a-z]{1,2}[a-z0-9]{1,2})\s*?(\d[a-z]{2})$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}