import Foundation
let pattern = #"([0-9.]+)(?:\n)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Code Goes Here $1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)