# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9.]+)(?:\n)?/Code Goes Here $1\n/gm;t' <<< "0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55."