const regex = /([0-9.]+)(?:\n)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9.]+)(?:\\n)?', 'gm')
const str = `0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55.`;
const subst = `Code Goes Here $1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);