using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9.]+)(?:\n)?";
string substitution = @"Code Goes Here $1\n";
string input = @"0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}