$re = '/([0-9.]+)(?:\n)?/m';
$str = '0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55.';
$subst = "Code Goes Here $1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;