# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9.]+)(?:\n)?"
test_str = ("0.11\n"
"0220550\n"
"5050\n"
"505050\n"
"5050\n"
"505\n"
"693\n\n"
"96969969969\n"
"32.33.3.3\n"
"5.55.")
subst = "Code Goes Here $1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.