import Foundation
let pattern = #"[^0-9a-zA-Z]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)