$re = '/[^0-9a-zA-Z]+/m';
$str = 'Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;