# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^0-9a-zA-Z]+/ /gm;t' <<< "Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake"