package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^0-9a-zA-Z]+`)
var str = `Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}