re = /[^0-9a-zA-Z]+/m
str = 'Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result