using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9a-zA-Z]+";
string substitution = @" ";
string input = @"Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}