use strict;
my $str = 'Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake';
my $regex = qr/[^0-9a-zA-Z]+/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";