// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^0-9a-zA-Z]+").unwrap();
let string = "Hiaity) **earthquake 2010 @#$%%^&*()_+ 2010 Haiti Earquake";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}