import Foundation
let pattern = #"<text(.[^>]+)>\n(\s+)(.+)\n(.+)<\/text>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动画:比例
</text>
<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动例
</text>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<text ${1}>${3}</text>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)