using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<text(.[^>]+)>\n(\s+)(.+)\n(.+)<\/text>";
string substitution = @"<text ${1}>${3}</text>";
string input = @"<text class=""wx-text_tz7UYs"" data-c_e_id=""wx-textf2d09dd7377909fe"">
测试动画:比例
</text>
<text class=""wx-text_tz7UYs"" data-c_e_id=""wx-textf2d09dd7377909fe"">
测试动例
</text>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}