const regex = new RegExp('<text(.[^>]+)>\\n(\\s+)(.+)\\n(.+)<\\/text>', 'g')
const str = `<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动画:比例
</text>
<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动例
</text>`;
const subst = `<text ${1}>${3}</text>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);