// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<text(.[^>]+)>\n(\s+)(.+)\n(.+)<\/text>").unwrap();
let string = "<text class=\"wx-text_tz7UYs\" data-c_e_id=\"wx-textf2d09dd7377909fe\">
测试动画:比例
</text>
<text class=\"wx-text_tz7UYs\" data-c_e_id=\"wx-textf2d09dd7377909fe\">
测试动例
</text>";
let substitution = "<text ${1}>${3}</text>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}