package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<text(.[^>]+)>\n(\s+)(.+)\n(.+)<\/text>`)
var str = `<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动画:比例
</text>
<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动例
</text>`
var substitution = "<text ${1}>${3}</text>"
fmt.Println(re.ReplaceAllString(str, substitution))
}