$re = '/<text(.[^>]+)>\n(\s+)(.+)\n(.+)<\/text>/';
$str = '<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动画:比例
</text>
<text class="wx-text_tz7UYs" data-c_e_id="wx-textf2d09dd7377909fe">
测试动例
</text>';
$subst = "<text ${1}>${3}</text>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;