import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<text(.[^>]+)>\\n(\\s+)(.+)\\n(.+)<\\/text>";
final String string = "<text class=\"wx-text_tz7UYs\" data-c_e_id=\"wx-textf2d09dd7377909fe\">\n"
+ " 测试动画:比例\n"
+ " </text>\n"
+ "<text class=\"wx-text_tz7UYs\" data-c_e_id=\"wx-textf2d09dd7377909fe\">\n"
+ " 测试动例\n"
+ " </text>";
final String subst = "<text ${1}>${3}</text>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}