// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mU)(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)"#).unwrap();
let string = "info : /** @Desc(\"{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).\") **/ Translator.transChoice(\"message.pagination.sondage\", this.length, {'start' : this.pagination.row_start, 'stop':_this.pagination.row_end, 'total': _this.pagination.total}, \"messages\")";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}