package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)`)
var str = `info : /** @Desc("{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).") **/ Translator.transChoice("message.pagination.sondage", this.length, {'start' : this.pagination.row_start, 'stop':_this.pagination.row_end, 'total': _this.pagination.total}, "messages")`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}