const regex = /(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\*+\\h*@Desc\\([\\\'\\"])(?<desc>.*)([\\\'\\"]\\);*)', 'm')
const str = `info : /** @Desc("{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).") **/ Translator.transChoice("message.pagination.sondage", this.length, {'start' : this.pagination.row_start, 'stop':_this.pagination.row_end, 'total': _this.pagination.total}, "messages")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}