import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*+\\h*@Desc\\([\\'\\\"])(?<desc>.*)([\\'\\\"]\\);*)";
final String string = "info : /** @Desc(\"{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).\") **/ Translator.transChoice(\"message.pagination.sondage\", this.length, {'start' : this.pagination.row_start, 'stop':_this.pagination.row_end, 'total': _this.pagination.total}, \"messages\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}