$re = '/(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)/mU';
$str = 'info : /** @Desc("{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).") **/ Translator.transChoice("message.pagination.sondage", this.length, {\'start\' : this.pagination.row_start, \'stop\':_this.pagination.row_end, \'total\': _this.pagination.total}, "messages")';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);