re = /(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)/m
str = 'info : /** @Desc("{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).") **/ Translator.transChoice("message.pagination.sondage", this.length, {\'start\' : this.pagination.row_start, \'stop\':_this.pagination.row_end, \'total\': _this.pagination.total}, "messages")'
# Print the match result
str.match(re) do |match|
puts match.to_s
end