use strict;
my $str = 'info : /** @Desc("{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).") **/ Translator.transChoice("message.pagination.sondage", this.length, {\'start\' : this.pagination.row_start, \'stop\':_this.pagination.row_end, \'total\': _this.pagination.total}, "messages")';
my $regex = qr/(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}