using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*+\h*@Desc\([\'\""])(?<desc>.*)([\'\""]\);*)";
string input = @"info : /** @Desc(""{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s)."") **/ Translator.transChoice(""message.pagination.sondage"", this.length, {'start' : this.pagination.row_start, 'stop':_this.pagination.row_end, 'total': _this.pagination.total}, ""messages"")";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}