import Foundation
let pattern = #"\{\{(\"{1}.+\"{1}) ?\| ?t ?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"text" placeholder="{{ "Company"|t }}
{{"You will be redirected to the Lightspeed Restaurant management application in " | t|raw}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}