using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{(\""{1}.+\""{1}) ?\| ?t ?";
string input = @"""text"" placeholder=""{{ ""Company""|t }}
{{""You will be redirected to the Lightspeed Restaurant management application in "" | t|raw}}
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}