// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\{\{(\"{1}.+\"{1}) ?\| ?t ?"#).unwrap();
let string = "\"text\" placeholder=\"{{ \"Company\"|t }}
{{\"You will be redirected to the Lightspeed Restaurant management application in \" | t|raw}}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}