const regex = /\{\{(\"{1}.+\"{1}) ?\| ?t ?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(\\"{1}.+\\"{1}) ?\\| ?t ?', '')
const str = `"text" placeholder="{{ "Company"|t }}
{{"You will be redirected to the Lightspeed Restaurant management application in " | t|raw}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}