#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{\{(\"{1}.+\"{1}) ?\| ?t ?"
Local $sString = ""text" placeholder="{{ "Company"|t }}" & @CRLF & _
"{{"You will be redirected to the Lightspeed Restaurant management application in " | t|raw}}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")