$re = '/\{\{(\"{1}.+\"{1}) ?\| ?t ?/';
$str = '"text" placeholder="{{ "Company"|t }}
{{"You will be redirected to the Lightspeed Restaurant management application in " | t|raw}}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);