re = /\{\{(\"{1}.+\"{1}) ?\| ?t ?/
str = '"text" placeholder="{{ "Company"|t }}
{{"You will be redirected to the Lightspeed Restaurant management application in " | t|raw}}
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end