// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)").unwrap();
let string = "https://www.facebook.com/j2teamnnl/
https://www.facebook.com/groups/j2team.community/
https://www.facebook.com/profile.php?id=100048240755558
h//www.facebook.com/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}