$re = '/(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)/m';
$str = 'https://www.facebook.com/j2teamnnl/
https://www.facebook.com/groups/j2team.community/
https://www.facebook.com/profile.php?id=100048240755558
h//www.facebook.com/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);