#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)"
Local $sString = "https://www.facebook.com/j2teamnnl/" & @CRLF & _
"https://www.facebook.com/groups/j2team.community/" & @CRLF & _
"https://www.facebook.com/profile.php?id=100048240755558" & @CRLF & _
"h//www.facebook.com/" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")