package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)`)
var str = `https://www.facebook.com/j2teamnnl/
https://www.facebook.com/groups/j2team.community/
https://www.facebook.com/profile.php?id=100048240755558
h//www.facebook.com/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}