using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)";
string input = @"https://www.facebook.com/j2teamnnl/
https://www.facebook.com/groups/j2team.community/
https://www.facebook.com/profile.php?id=100048240755558
h//www.facebook.com/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}